summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 25 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d533f7eb528a..a3a1470041b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,14 @@
# Maintainer: Alex Forencich <alex@alexforencich.com>
-pkgname=python-pyvisa-py-git
-pkgver=0.1.r64.gef0fc09
+pkgname=(python-pyvisa-py-git python2-pyvisa-py-git)
+pkgver=0.2.r153.g985e470
pkgrel=1
pkgdesc="A pure python backend for PyVISA"
arch=('any')
-url="https://github.com/hgrecco/pyvisa-py"
+url="https://github.com/pyvisa/pyvisa-py"
license=('MIT')
-depends=('python' 'python-pyvisa')
-makedepends=('git' 'python-distribute' 'python-docutils')
-provides=('python-pyvisa-py')
+makedepends=('git')
-_gitroot='https://github.com/hgrecco/pyvisa-py.git'
+_gitroot='https://github.com/pyvisa/pyvisa-py.git'
_gitname='pyvisa-py'
source=("$_gitname::git+$_gitroot")
@@ -25,8 +23,27 @@ build() {
cd "$srcdir/$_gitname"
}
-package() {
+package_python-pyvisa-py-git() {
+ depends=('python' 'python-distribute' 'python-docutils' 'python-pyvisa')
+ provides=('python-pyvisa-py')
+ conflicts=('python-pyvisa-py')
+ optdepends=(
+ 'python-pyvisa-py: Pure Python backend'
+ )
+
cd "$srcdir/$_gitname"
python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
}
+package_python2-pyvisa-py-git() {
+ depends=('python2' 'python2-distribute' 'python2-docutils' 'python2-pyvisa')
+ provides=('python2-pyvisa-py')
+ conflicts=('python2-pyvisa-py')
+ optdepends=(
+ 'python2-pyvisa-py: Pure Python backend'
+ )
+
+ cd "$srcdir/$_gitname"
+ python2 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+}
+