summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb1fa1a844ba..6d02bed42168 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,34 @@
pkgname=python-q2-types
_pkgname=q2-types
-pkgver=2020.11.0.dev0
+pkgver=2021.2.0.dev0
pkgrel=1
pkgdesc="Definitions of common QIIME 2 types."
arch=('x86_64')
url="https://qiime2.org"
license=('BSD')
-depends=('python' 'python-qiime2' 'python-biom-format' 'python-scikit-bio' 'python-h5py' 'python-pandas' 'python-ijson')
+depends=(
+python
+python-qiime2
+python-biom-format
+python-scikit-bio
+python-h5py
+python-pandas
+python-ijson
+)
makedepends=('python-setuptools')
-source=("https://github.com/qiime2/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('f597c68a6b6ef9dae36cfe1ae3dadbb5078ff7c845e4694847daf7e1562bae72')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/qiime2/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('ec0cbd2cdc20ee2dd9922b5cf40c66d52a637a14982c74ee8d3f022053db994c')
build() {
cd "$srcdir/$_pkgname-$pkgver"
python setup.py build
}
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py test
+}
package(){
cd "$srcdir/$_pkgname-$pkgver"