summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 22 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eed6f013036b..d014d852a6cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,40 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: Alberto Redondo <albertomost at gmail dot com>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: Chih-Hsuan Yen <yan12125@gmail.com>
# Contributor: Alexander 'z33ky' Hirsch <1zeeky@gmail.com>
-_pkgname='requests-futures'
-pkgname="python-${_pkgname}"
+_pkgname=requests-futures
+pkgname=python-${_pkgname}
pkgver=1.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='Asynchronous Python HTTP Requests for Humans'
arch=('any')
url='https://github.com/ross/requests-futures'
_url_pypi='https://pypi.org/project/requests-futures'
-license=('APACHE')
+license=('Apache')
depends=('python-requests')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz)
sha256sums=('35547502bf1958044716a03a2f47092a89efe8f9789ab0c4c528d9c9c30bc148')
build() {
- cd "${_pkgname}-${pkgver}"
+
+ cd ${_pkgname}-${pkgver}
+
python setup.py build
+
}
package() {
- cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
-}
-# vim: ts=2 sw=2 et:
+ cd ${_pkgname}-${pkgver}
+
+ python setup.py install \
+ -O1 \
+ --root="${pkgdir}" \
+ --skip-build
+
+ install -Dvm644 'README.rst' \
+ -t "${pkgdir}/usr/share/doc/${pkgname}"
+
+}