summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 8 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56a04088467b..d5d72ddcf54c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,22 @@
# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
pkgbase='python-resize-image'
-pkgname=('python-resize-image' 'python2-resize-image')
-pkgver='1.1.19'
-pkgrel='2'
+pkgname="${pkgbase}"
+pkgver='1.1.20'
+pkgrel='1'
pkgdesc="A Small python package to easily resize images"
arch=("any")
-url="https://github.com/VingtCinq/${pkgname}"
-makedepends=('python' 'python-setuptools'
- 'python2' 'python2-setuptools')
+url="https://github.com/VingtCinq/${pkgbase}"
+depends=('python-requests' 'python-pillow')
+makedepends=('python' 'python-setuptools')
license=('MIT')
source=("https://pypi.io/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
"https://raw.githubusercontent.com/VingtCinq/${pkgbase}/master/LICENSE")
-sha256sums=('2aea25e9811fd44d4cb8fef82059ace114f6cc72bbef059f69b0b7f79f55e03e'
+sha256sums=('b055dab919d623ece8ec95262d4bdbf006cb1a10e818e9b36221c8b1885f9922'
'bf3a8525e859c6ce1c4b6b463f65ffbe331480aae194c63e896a56d4d7708f08')
-build() {
- cd "${srcdir}/${pkgbase}-${pkgver}"
- python setup.py build
-}
-
-package_python-resize-image() {
- depends=('python-requests' 'python-pillow')
-
+package() {
cd "${srcdir}/${pkgbase}-${pkgver}"
python setup.py install -O1 --root="${pkgdir}"
install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}
-
-package_python2-resize-image() {
- depends=('python2-requests' 'python2-pillow')
-
- cd "${srcdir}/${pkgbase}-${pkgver}"
- python2 setup.py install -O1 --root="${pkgdir}"
- install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
-}