summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 81ee04814537..58bf8c7968b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,22 @@
pkgname=python-secure
_pypiname=secure
pkgver=0.3.0
-pkgrel=2
+pkgrel=3
pkgdesc="secure.py is a lightweight package that adds optional security headers for Python web frameworks."
url="https://github.com/TypeError/secure.py/releases"
arch=('any')
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=(${_pypiname}-${pkgver}.tar.gz::"https://github.com/TypeError/secure/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('a9b5a61a78cd53c4b5c186579964025ff9d51ebb66bd66492f027240088e8984')
+build() {
+ cd "${_pypiname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd ${_pypiname}-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ cd "${_pypiname}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}