summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f88ebc0fadc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+pkgname=python-sentiment-investor
+_pkgname=${pkgname:7}
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Access the Sentiment Investor API through Python"
+arch=('any')
+url="https://pypi.org/project/${_pkgname}"
+license=('MIT')
+makedepends=(python-build python-installer python-wheel python-poetry)
+depends=(python python-requests python-websocket-client python-beartype)
+source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha256sums=('1b1969058ed540ef7059a54c146bc7b1e424b55c405607d4b407d476e562504e')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}