summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab25f9f4850f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ronuk Raval <ronuk.raval at gmail dot com>
+
+pkgname=python-shortcutter
+pkgver=0.1.20
+pkgrel=1
+pkgdesc="Easy cross-platform creation of shortcuts supporting virtual and Anaconda environments"
+arch=('any')
+url="https://github.com/kiwi0fruit/shortcutter"
+license=('MIT')
+depends=(python)
+source=(
+ ${pkgname}-${pkgver}.tar.gz::https://github.com/kiwi0fruit/shortcutter/archive/${pkgver}.tar.gz
+)
+sha256sums=(
+ 859ddf79a061071544cd4dcb30a77f390c97ed8819d5cf05bec4e564d8ea7b95
+)
+
+build() {
+ cd "shortcutter-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "shortcutter-${pkgver}"
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}