summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 461248ec557b..d443b4920803 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,26 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor : Repentinus <arch at repentinus dot eu>
# Contributor : Simon Doppler <dop dot simon at gmail dot com>
-_pkgname=simplekml
pkgname=python-simplekml
-pkgver=1.3.5
+pkgver=1.3.6
pkgrel=1
pkgdesc="KML generation helpers"
arch=('any')
url="https://simplekml.readthedocs.io/en/latest/"
license=('LGPL3')
depends=('python')
-source=("https://files.pythonhosted.org/packages/62/de/a75c0c8341a2edd186e14648c231c92c9e672dd38c544089615140c28ac6/simplekml-${pkgver}.tar.gz")
-sha256sums=('657b4e20177299a4e80bacfafff1f91102010bc23dc0ce7a7ae43bdd4246049e')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/s/simplekml/simplekml-$pkgver.tar.gz")
+sha256sums=('cda687be2754395fcab664e908ebf589facd41e8436d233d2be37a69efb1c536')
+
+build() {
+ cd "simplekml-$pkgver"
+ python setup.py build
+}
package() {
- cd "${_pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir"
+ cd "simplekml-$pkgver"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}