summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 17 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61e4aa6a154e..886c219ff861 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: James Duley <jagduley gmail>
pkgname=python-slycot-git
-pkgver=292.2f31897
+pkgver=517.a40505a
pkgrel=1
pkgdesc="Python wrapper for selected SLICOT routines, notably including solvers for Riccati, Lyapunov and Sylvester equations."
arch=('i686' 'x86_64')
@@ -21,16 +21,30 @@ pkgver() {
echo $(git rev-list --count master).$(git rev-parse --short master)
}
+prepare() {
+ cd "$srcdir/Slycot"
+ git submodule update --init
+}
+
build() {
cd "$srcdir/Slycot"
- python setup.py build
+ # Link against the Generic NetLIB blas/lapack ABI. If openblas is installed
+ # instead of blas, that one will provide the library. Same mechanism as in
+ # Extra/python-numpy
+ export BLA_VENDOR=Generic
+ python setup.py build -G "Unix Makefiles"
+}
+
+check() {
+ cd "$srcdir/Slycot"
+ pytest
}
package() {
export LDFLAGS="$LDFLAGS -shared"
cd "$srcdir/Slycot"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ python setup.py install -G "Unix Makefiles" --prefix=/usr --root="${pkgdir}" --optimize=1
}
# vim:set ts=2 sw=2 et: