summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7ff4cb61952..a22fc4fc2906 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,17 @@ arch=(any)
url="https://github.com/Andre0512/speedport-api"
license=(MIT)
depends=(python-aiohttp python-pycryptodome)
-makedepends=(git python-setuptools python-pylint mypy flake8 python-black)
+makedepends=(git python-build python-installer python-wheel python-setuptools python-pylint mypy flake8 python-black)
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
b2sums=("dc51548de5e6271f31e087cf8ba61e637b3156ad5695d2bb98efe692c423be5d65eda4ad57bce9da43b1ee0343233cd41eb5e7e17b57f9eb41823ae2a96b052b")
build() {
cd speedport-api-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd speedport-api-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}