summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d843988d6742..05b9a0f91fa2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ryan Greenblatt <ryan_greenblatt at brown dot edu>
pkgname=python-sympy-git
-pkgver=1.6.r1720.ge32abe4b08
+pkgver=1.6.r1751.gb88c69a1ed
pkgrel=1
pkgdesc="Computer algebra system (CAS) in Python, written in pure Python - git version"
arch=('any')
@@ -12,7 +12,8 @@ conflicts=('python-sympy')
provides=('python-sympy')
optdepends=('ipython: user friendly interface for isympy')
makedepends=('python-setuptools' 'git')
-source=("$pkgname::git+https://github.com/sympy/sympy.git")
+source=("git+https://github.com/sympy/sympy.git")
+srcdirname="sympy"
sha256sums=('SKIP')
if [ -n "$VIRTUAL_ENV" ]; then
@@ -22,12 +23,12 @@ if [ -n "$VIRTUAL_ENV" ]; then
fi
pkgver() {
- cd "$pkgname"
+ cd "$srcdirname"
git describe --long --tags | sed 's/sympy-\(.*\)/\1/g;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$pkgname"
+ cd "$srcdirname"
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}