summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cedc2eaff840
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# PKGBUILD generated by pipman
+# Python package author: Léo Flaventin Hauchecorne <hl037.prog@gmail.com>
+pkgname=python-tempiny
+pkgver=1.1
+pkgrel=1
+pkgdesc="Tiny template engine"
+arch=(any)
+url="https://github.com/hl037/tempiny"
+license=(LGPLv2.1+)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="tempiny" tempiny==1.1
+}
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p $pkgdir/"$sitepackages"
+ cp -r $srcdir/tempiny/* $pkgdir/"$sitepackages"
+} \ No newline at end of file