summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 29 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b74845c829be..28139591d53e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
# Maintainer: David McInnis <dave@dave3.xyz>
pkgbase="python-theano"
-pkgname=("python-theano" "python2-theano")
+pkgname=(
+ "python-theano"
+ #"python2-theano"
+)
_pkgname="Theano"
-pkgver="1.0.4"
-pkgrel="3"
+pkgver="1.0.5"
+pkgrel="1"
pkgdesc='Definition and optimized evaluation of mathematical expressions on Numpy arrays.'
arch=('any')
url='http://www.deeplearning.net/software/theano/'
license=('BSD')
-makedepends=('python-distribute' 'python2-distribute')
+makedepends=(
+ 'python-distribute'
+ #'python2-distribute'
+ )
#checkdepends=('python-nose' 'python-parameterized' 'python2-nose' 'python2-parameterized')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('35c9bbef56b61ffa299265a42a4e8f8cb5a07b2997dabaef0f8830b397086913')
+sha256sums=('6e9439dd53ba995fcae27bf20626074bfc2fff446899dc5c53cb28c1f9202e89')
prepare() {
cd "${_pkgname}-${pkgver}"
@@ -29,9 +35,9 @@ prepare() {
}
build() {
- msg "Building Python 2"
- cd "$srcdir/${_pkgname}-${pkgver}-py2"
- python2 setup.py build
+ # msg "Building Python 2"
+ # cd "$srcdir/${_pkgname}-${pkgver}-py2"
+ # python2 setup.py build
msg "Building Python 3"
cd "$srcdir/${_pkgname}-${pkgver}"
@@ -52,21 +58,21 @@ build() {
# nosetests3 -vv -d
#}
-package_python2-theano() {
- depends=('python2-numpy')
- optdepends=('python2-sympy: Recommended'
- 'python2-scipy: Recommended'
- 'python2-pycuda'
- 'python2-pydot-ng: Preferred over python-pydot'
- 'python2-pydot'
- 'python2-pygpu-git'
- 'python2-mpi4py: minimal support for opencl')
- cd "$srcdir/${_pkgname}-${pkgver}-py2"
- python2 setup.py install --root="$pkgdir"/ --optimize=1 --skip-build
- mv "${pkgdir}/usr/bin/theano-cache" "${pkgdir}/usr/bin/theano2-cache"
- mv "${pkgdir}/usr/bin/theano-nose" "${pkgdir}/usr/bin/theano2-nose"
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python2-theano/LICENSE.txt"
-}
+#package_python2-theano() {
+# depends=('python2-numpy')
+# optdepends=('python2-sympy: Recommended'
+# 'python2-scipy: Recommended'
+# 'python2-pycuda'
+# 'python2-pydot-ng: Preferred over python-pydot'
+# 'python2-pydot'
+# 'python2-pygpu-git'
+# 'python2-mpi4py: minimal support for opencl')
+# cd "$srcdir/${_pkgname}-${pkgver}-py2"
+# python2 setup.py install --root="$pkgdir"/ --optimize=1 --skip-build
+# mv "${pkgdir}/usr/bin/theano-cache" "${pkgdir}/usr/bin/theano2-cache"
+# mv "${pkgdir}/usr/bin/theano-nose" "${pkgdir}/usr/bin/theano2-nose"
+# install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python2-theano/LICENSE.txt"
+#}
package_python-theano() {
depends=('python-numpy')