summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0abddd6b13d3..736343d2b861 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
pkgname=python-tikzplotlib-git
-pkgver=0.9.16.r2.g1e30229
-pkgrel=3
+pkgver=0.10.1.r2.g450712b
+pkgrel=1
pkgdesc="Convert matplotlib figures into TikZ/PGFPlots"
-url="https://github.com/nschloe/tikzplotlib"
-makedepends=(git python-build)
-depends=(python python-matplotlib python-numpy python-pillow)
+url="https://github.com/texworld/tikzplotlib"
+makedepends=(git python-flit-core python-build python-installer python-wheel)
+depends=(python python-matplotlib python-numpy python-pillow python-webcolors)
provides=("python-tikzplotlib=$pkgver")
conflicts=(python-matplotlib2tikz python-tikzplotlib)
replaces=(python-matplotlib2tikz)
@@ -21,15 +21,11 @@ pkgver() {
build() {
cd "$srcdir/tikzplotlib"
- python -m build
+ python -m build --wheel --no-isolation
}
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
- mkdir -p "$site"
-
cd "$srcdir/tikzplotlib"
- local cleanver="$(git describe --tags --abbrev=0 | sed 's/^v//')"
- unzip "dist/tikzplotlib-$cleanver-py3-none-any.whl" -d "$site"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}