summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 23 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e227269d79fc..700180bbf912 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,31 @@
-# Maintainer: Sophie Tauchert <sophie@999eagle.moe>
-
-_pkgname=timeago
-pkgname=python-${_pkgname}
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+# Contributor: Sophie Tauchert <sophie@999eagle.moe>
+pkgname=python-timeago
+_name=${pkgname#python-}
pkgver=1.0.16
-pkgrel=2
-pkgdesc="Very simple python library, used to format datetime with \`***time ago\` statement."
+pkgrel=3
+pkgdesc="Simple library used to format datetime with \`***time ago\` statement."
arch=('any')
url="https://github.com/hustcc/timeago"
license=('MIT')
depends=('python')
-makedepends=('python-installer')
-provides=()
-# use wheel distribution directly as no source distribution is available
-source=("https://files.pythonhosted.org/packages/py3/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}-py3-none-any.whl"
- "https://raw.githubusercontent.com/hustcc/timeago/master/LICENSE")
-sha256sums=('9b8cb2e3102b329f35a04aa4531982d867b093b19481cfbb1dac7845fa2f79b0'
- 'e2a15cd0b56cfffbb99e27caeb87afe58ff78097d9c3bd3aea2a251145479912')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+source=("$_name-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('7b54b88b3d0566cbf01ca11077dad8f7ae07a4318479e3d1b30feebe85f7137f')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd "$_name-$pkgver"
+ python test/testcase.py
+}
package() {
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- python -m installer --destdir="$pkgdir" "${_pkgname}-${pkgver}-py3-none-any.whl"
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}