summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca995a525fa4..b0bf512530f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=python-torf
-pkgver=4.2.4
+pkgver=4.2.6
pkgrel=1
pkgdesc='Python module to create, parse and edit torrent files and magnet links'
arch=('any')
@@ -12,7 +12,7 @@ makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel
checkdepends=('python-pytest' 'python-pytest-httpserver' 'python-pytest-mock' 'python-pytest-xdist')
BUILDENV+=('!check')
source=("https://github.com/rndusr/torf/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('9263dd24c4437a0cdc6bf5fe4325eb26cdf80824640b4c2746e0b59e15107f07')
+sha256sums=('5ddbef64d8660a23370935b442b458018eec7e4fb0c9764db260d7919cd8f1f6')
build() {
cd "torf-${pkgver}"
@@ -26,4 +26,8 @@ check() {
package() {
python -m installer --destdir="$pkgdir" "torf-${pkgver}/dist"/*.whl
+
+ local _site_pkgs
+ _site_pkgs="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ rm -r "${pkgdir}${_site_pkgs}"/{docs,tests}
}