diff options
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 7 |
1 files changed, 7 insertions, 0 deletions
@@ -17,6 +17,13 @@ build() { python -m build --wheel --skip-dependency-check --no-isolation } +check() { + cd ${_base}-${pkgver} + python -m venv --system-site-packages test-env + test-env/bin/python -m installer dist/*.whl + test-env/bin/python -m unittest +} + package() { cd ${_base}-${pkgver} PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl |