summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 259e0cc0ac4f..38e36334c051 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,22 @@
# Contributor: Ting-Wei Lan <lantw44@gmail.com>
# Contributor: Oliver Mangold <omangold@gmail.com>
-_name=uncompyle6
-pkgname="python-${_name}"
-pkgver=3.9.0
+pkgname=python-uncompyle6
+_name=${pkgname#python-}
+pkgver=3.9.1
pkgrel=1
pkgdesc="Python byte-code disassembler and source-code converter."
arch=('any')
url="https://github.com/rocky/python-uncompyle6/"
license=('MIT')
-depends=('python-spark-parser>=1.8.9'
+depends=('python-click'
+ 'python-spark-parser>=1.8.9'
'python-spark-parser<1.9.0'
- 'python-xdis>=6.0.2'
- 'python-xdis<6.1.0')
+ 'python-xdis>=6.0.8'
+ 'python-xdis<6.2.0')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('1e6a902de60ea5c3f7d2af7e2745006b4e4b9bdede888a07f8441c9938f2ee7d')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('c451c38eb3c5cc834eb8b8a9e6e0b0cf3226e4d94d08fd276dd03fe9158edb27')
package() {
cd "$srcdir/$_name-$pkgver"