summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f59c0aa60c50..aa3700881f9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,27 @@
-# Maintainer: Uko Koknevics <perkontevs@gmail.com>
# Python package author: Charles Leifer <UNKNOWN>
+# Maintainer: Uko Koknevics <perkontevs@gmail.com>
+# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
+
pkgname=python-unqlite
-pkgver=0.7.1
+pkgver=0.8.1
pkgrel=1
pkgdesc="Fast Python bindings for the UnQLite embedded NoSQL database."
-arch=(any)
+arch=('x86_64' 'i686')
url="https://github.com/coleifer/unqlite-python"
license=(MIT)
-makedepends=("python" "python-pip")
+makedepends=('python-pip' 'git' 'cython')
+depends=('python')
+source=("git+https://github.com/coleifer/unqlite-python.git#tag=${pkgver}")
+md5sums=('SKIP')
+
build() {
- pip install --no-deps --target="unqlite" unqlite
+ cd "$srcdir/unqlite-python"
+ python setup.py build
}
+
package() {
- mkdir -p $pkgdir/usr/lib/python3.6/site-packages/
- cp -r $srcdir/unqlite/* $pkgdir/usr/lib/python3.6/site-packages/
+ cd "$srcdir/unqlite-python"
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}