summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57906e45735f..6acb12345fa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: BrainDamage
pkgname="python-wfdb"
-pkgver=4.1.2
+pkgver=4.3.0
_basename='wfdb-python'
_dirname="${_basename}-${pkgver}"
-pkgrel=2
+pkgrel=1
pkgdesc="Library of tools for reading, writing, and processing WFDB signals and annotations"
arch=(any)
url="https://github.com/MIT-LCP/wfdb-python"
license=("MIT")
depends=("python" "python-numpy" "python-scipy" "python-matplotlib" "python-pandas" "python-requests" "python-soundfile")
-sha256sums=('c96c62b8abede8c0987c77d49285c923f114787a96d110cf95dac5e5d56360cd')
+sha256sums=('a5df93103f65b09aaa63eb41fd2b22b9df89479860b4cc8cf8ea4c0f62cc393f')
source=("https://github.com/MIT-LCP/${_basename}/archive/v${pkgver}.tar.gz")
-makedepends=('python-build' 'python-installer' 'python-wheel' 'python-poetry' 'python-sphinx')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-poetry' 'python-sphinx' 'python-hatchling')
checkdepends=('python-pytest' 'python-pytest-xdist' 'python-pylint' 'python-black')
build() {