summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 17 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6fec4979bc7..52de0f1a8ee9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: Pierre Chapuis <arch@catwell.info>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
-_pkgname='wimpy'
-pkgname="python-${_pkgname}"
+pkgname="python-wimpy"
pkgver=0.6
-pkgrel=2
-pkgdesc='Anti-copy-pasta'
-arch=('any')
-url='https://github.com/wimglenn/wimpy'
-_url_pypi='https://pypi.org/project/wimpy'
-license=('MIT')
-depends=('python')
-makedepends=('python-setuptools')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('014d21a31980eab48b92c4210e9fdba643b79f7081c64ea9bc97f2be9db9bd58')
+pkgrel=3
+pkgdesc="Personal Python libraries of @wimglenn"
+arch=("any")
+url="https://github.com/wimglenn/wimpy"
+license=("MIT")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=("014d21a31980eab48b92c4210e9fdba643b79f7081c64ea9bc97f2be9db9bd58")
+depends=("python")
+makedepends=("python-setuptools")
build() {
- cd "${_pkgname}-${pkgver}"
+ cd "wimpy-$pkgver"
python setup.py build
}
package() {
- cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd "wimpy-$pkgver"
+ python setup.py install --root="$pkgdir" -O1
+ install -Dm644 README.rst "$pkgdir/usr/share/doc/$pkgname/README.rst"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim: ts=2 sw=2 et: