summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7f695483020..031d9b6ad317 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ arch=('i686' 'x86_64')
license=('PSF')
url="http://www.python.org/"
depends=('bash')
-makedepends=()
+makedepends=(tk tcl)
optdepends=()
options=('!makeflags')
source=(http://www.python.org/download/releases/$pkgver/Python-$pkgver.tar.gz)
@@ -18,8 +18,15 @@ sha1sums=('3cc7f523ae529384ea78b41d1c48011484407442')
build() {
cd "$srcdir/Python-$pkgver"
+ # enable more modules
+ echo 'termios termios.c' >> Modules/Setup.in
+ echo 'crypt cryptmodule.c -lcrypt' >> Modules/Setup.in
+ echo 'resource resource.c' >> Modules/Setup.in
+ echo '_tkinter _tkinter.c tkappinit.c -DWITH_APPINIT -lX11 -ltk8.5 -ltcl8.5' >> Modules/Setup.in
+
export OPT="$CFLAGS"
./configure --prefix=/usr
+
make
}