summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD80
1 files changed, 59 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f34e906f4d2c..45fd608b1796 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,78 @@
-# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# SPDX-License-Identifier: AGPL-3.0
+#
+# Maintainer: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
+# Maintainer: Truocolo <truocolo@aol.com>
+# Contributor: Marcell Meszaros (MarsSeed) <marcell.meszaros@runbox.eu>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Lex Black <autumn-wind at web dot de>
# Contributor: Igor Nemilentsev <trezorg@gmail.com>
# Contributor: Alexander Diana <alexander@rouk.org>
-pkgname='python2-bcrypt'
-_name="${pkgname#python2-}"
+_pkg="bcrypt"
+_py="python2"
+pkgname="${_py}-${_pkg}"
pkgver=3.1.7
-pkgrel=5
-pkgdesc='Modern password hashing for your software and your servers'
-arch=('x86_64')
-url="https://pypi.org/project/${_name}/${pkgver}/"
-license=('Apache')
+pkgrel=4
+_pkgdesc=(
+ "Modern password hashing for"
+ "your software and your servers"
+)
+pkgdesc="${_pkgdesc[*]}"
+arch=(
+ 'x86_64'
+ 'i686'
+ 'pentium4'
+ 'arm'
+ 'armv6l'
+ 'armv7h'
+ 'aarch64'
+ 'mips'
+ 'powerpc'
+)
+_ns='pyca'
+url="https://github.com/${_ns}/${_pkg}"
+license=(
+ 'Apache'
+)
depends=(
- 'glibc'
- 'python2'
'python2-cffi'
'python2-six'
)
-makedepends=('python2-setuptools')
-checkdepends=('python2-pytest')
-_tarname="${_name}-${pkgver}"
-source=("${_tarname}.tar.gz::https://github.com/pyca/${_name}/archive/${pkgver}.tar.gz")
-sha512sums=('bfe487ac43aa5081a16c7f67787c2aec777a9c42f3f0f64d4dd238e6cf135e248e806a675ecdc5240066e2b5a31773f9c5dd939479e96ec25357e27bced01409')
+makedepends=(
+ 'python2-setuptools'
+)
+checkdepends=(
+ 'python2-pytest'
+)
+source=(
+ "${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
+)
+sha512sums=(
+ 'bfe487ac43aa5081a16c7f67787c2aec777a9c42f3f0f64d4dd238e6cf135e248e806a675ecdc5240066e2b5a31773f9c5dd939479e96ec25357e27bced01409'
+)
build() {
- cd "${_tarname}"
- python2 setup.py build
+ cd \
+ "${_pkg}-${pkgver}"
+ "${_py}" \
+ setup.py \
+ build
}
check() {
- cd "${_tarname}"
- PYTHONPATH="$PWD/build/lib.linux-$CARCH-2.7" pytest2
+ cd \
+ "${_pkg}-${pkgver}"
+ PYTHONPATH="$PWD/build/lib.linux-${CARCH}-2.7" \
+ pytest2
}
package() {
- cd "${_tarname}"
- python2 setup.py install --prefix='/usr' --root="${pkgdir}"
+ cd \
+ "${_pkg}-${pkgver}"
+ "${_py}" \
+ setup.py \
+ install \
+ --root="$pkgdir"
}
+
+# vim:set sw=2 sts=-1 et: