summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 16 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6dd5525285b9..53f8d5ce45f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,31 @@
-# Maintainer: Cedric Girard <girard.cedric@gmail.com>
-_pythonmod=boto3
+# Maintainer: Andrea Scarpino <andrea at archlinux.org>
+# Contributor: Jonathan Steel <jsteel at archlinux.org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+
pkgname=python2-boto3
-pkgver=1.5.13
+pkgver=1.10.39
pkgrel=1
-pkgdesc="The AWS SDK for Python"
+pkgdesc='The AWS SDK for Python'
arch=('any')
-url="http://pypi.python.org/pypi/${_pythonmod}"
license=('Apache')
-depends=(
- 'python2'
- 'python2-botocore>=1.8.27'
- 'python2-botocore<1.9.0'
- 'python2-jmespath>=0.7.1'
- 'python2-jmespath<1.0.0'
- 'python2-s3transfer>=0.1.10'
- 'python2-s3transfer<0.2.0'
- )
+url='https://github.com/boto/boto3'
+depends=('python2-botocore' 'python2-jmespath' 'python2-s3transfer')
makedepends=('python2-setuptools')
-source=("https://pypi.io/packages/source/${_pythonmod:0:1}/${_pythonmod}/${_pythonmod}-$pkgver.tar.gz")
-md5sums=('b4355040831b554e8aa03ea326757b26')
+# checkdepends=('python2-coverage' 'python2-nose' 'python2-mock')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/boto/boto3/archive/$pkgver.tar.gz")
+sha512sums=('6f1e5fbb10efb5ddf44f1769f83896b6dafad65027e85b94f3ac96f3925fa2ed443ea7f7befdeb97b3748d8f7f6bf2c385b901bea353571885390b503e4a25d4')
build() {
- cd ${srcdir}/${_pythonmod}-$pkgver
+ cd boto3-$pkgver
python2 setup.py build
}
check() {
- cd ${srcdir}/${_pythonmod}-$pkgver
- python2 setup.py test
+ cd boto3-$pkgver
+ # scripts/ci/run-tests
}
package() {
- cd ${srcdir}/${_pythonmod}-$pkgver
- python2 setup.py install --root=${pkgdir}
+ cd boto3-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
}