summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18aa91b2e6f6..3389137bb586 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,29 @@
# Maintainer: Rich Lindsley <richli.ff at gmail dot com>
pkgname=python2-bufr
_py_pkgname=python-bufr # The pypi package name
-pkgver="0.2.5"
+pkgver=9bce29b
_py_pkgver="0.2-5" # the official version has a hyphen
-pkgrel=3
+pkgrel=1
pkgdesc="Generic Python BUFR file reader based on ECMWF BUFR library"
arch=('i686' 'x86_64')
url="https://github.com/pytroll/python-bufr"
license=('GPL3')
depends=('python2')
-makedepends=('python2-numpy' 'eccodes')
+makedepends=('git' 'python2-numpy' 'eccodes')
options=(!emptydirs)
-source=(https://github.com/pytroll/python-bufr/archive/v0.2-5.tar.gz)
-md5sums=('78cb04b43e61d7c097a0b8f8c805ab3f')
+source=(git://github.com/pytroll/python-bufr.git patch.numpy)
+md5sums=('SKIP'
+ '0f451c84f573da6e902bba627db1c6fc')
+
+pkgver() {
+ cd $srcdir/$_gitname
+ # Use the tag of the last commit
+ git describe --always | sed 's|-|.|g'
+}
build() {
- cd "$srcdir/$_py_pkgname-$_py_pkgver/bufr"
+ cd "$srcdir/$_py_pkgname/bufr"
+ patch -p2 -i $srcdir/patch.numpy
# We enforce this to be a strictly python2 package
sed -i -e "s|^#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
@@ -27,7 +35,7 @@ build() {
}
package() {
- cd "$srcdir/$_py_pkgname-$_py_pkgver/bufr"
+ cd "$srcdir/$_py_pkgname/bufr"
python2 setup.py install --root="$pkgdir/" --optimize=1
}