summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 803e21af7d03..0fd2246a2beb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=python2-deap
-pkgver=1.0.2
+pkgver=1.2.2
pkgrel=1
pkgdesc="Distributed Evolutionary Algorithms in Python"
arch=('any')
@@ -7,11 +7,11 @@ url="https://github.com/DEAP/deap"
license=('LGPL')
depends=('python2' 'python2-pysqlite')
optdepends=("python2-numpy: for CMA-ES" "python2-matplotlib: for visualization" "python2-scoop: for computation distribution")
-source=("https://pypi.python.org/packages/source/d/deap/deap-$pkgver.post2.tar.gz")
-md5sums=('ccf5ed7562e4d6236c9416e3b5a9d941')
+source=("https://github.com/DEAP/deap/archive/$pkgver.tar.gz")
+md5sums=('49a80a4033a6869a15cca24ea4982910')
package() {
- cd "$srcdir/deap-$pkgver"
+ cd "deap-$pkgver"
find . -name '*.py' -exec sed -i -e '1 s/python\s*$/python2/' {} \;
python2 setup.py install --root="$pkgdir/" --optimize=1
}