summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 427169d8dca5..82d332544db0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,24 @@
# Contributor: Felix Yan <felixonmars@archlinux.org>
pkgname=python2-filelock
pkgver=3.2.1
-pkgrel=2
+pkgrel=3
pkgdesc='A platform independent file lock'
url='https://github.com/benediktschmitt/py-filelock'
-_name=${url##*/}
+_name=${url##*-}
license=('custom:Unlicense')
arch=('any')
depends=('python2')
makedepends=('python2-setuptools-scm')
-checkdepends=('python2-pytest' 'python2-pytest-cov' 'python2-pytest-timeout')
+checkdepends=('python2-pytest' 'python2-pytest-timeout')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('888bbcb7eb839f40947867a21eddf96ffcbc7e70bdcb3b18fbed115dbf6c8a6e')
+sha256sums=('9bb3a841fb7629eb39edfff49c936b387d7f4288341c4c0de525a16b7cb01153')
+
+prepare() {
+ cd "$srcdir/$_name-$pkgver"
+
+ # Make python2-pytest-cov no longer a requirement
+ sed -i /-cov/d setup.cfg
+}
build() {
cd "$srcdir/$_name-$pkgver"