summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 11 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d36a60a0b607..75298635cde1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,30 @@
# Maintainer: Firas Zaidan <firas@zaidan.de>
+# Contributor: Erich Eckner <arch at eckner dot net>
# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
# Contributor: Sebastien Binet <binet@lblbox>
pkgname=python2-numexpr
-pkgver=2.6.9
+pkgver=2.7.3
pkgrel=1
pkgdesc="Fast numerical array expression evaluator for Python, NumPy, PyTables, pandas"
url="https://github.com/pydata/numexpr"
-arch=('x86_64')
+arch=('x86_64' 'i686' 'pentium4')
license=('MIT')
-makedepends=('python2-setuptools' 'python2-numpy')
-source=($pkgname-$pkgver.tar.gz::https://github.com/pydata/numexpr/archive/v$pkgver.tar.gz)
-sha1sums=('db6cbb412fb1f85f87814002b88d0e479cf3ac51')
-
-prepare() {
- cd "$srcdir/numexpr-$pkgver"
-
- sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
- -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
- -i $(find . -name '*.py')
-}
+depends=(
+ 'python2>=2.7'
+ 'python2<2.8'
+ 'python2-numpy'
+)
+makedepends=('python2-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/pydata/numexpr/archive/v$pkgver.tar.gz")
+sha256sums=('00d6b1518605afe0ed10417e0ff07123e5d531c02496c6eed7dd4b9923238e1e')
build() {
cd "$srcdir"/numexpr-$pkgver
python2 setup.py build
}
-
package() {
- depends=('python2-numpy')
-
cd "$srcdir"/numexpr-$pkgver
-
python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
-
install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}