summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bf586a9e09e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Florian Pritz <bluewind@xinu.at>
+# Contributor: Christian Hesse <mail@eworm.de>
+# Contributor/Submitter: <p.janouch@gmail.com>
+
+pkgname=python2-pivy
+pkgver=20101207
+pkgrel=1
+pkgdesc="Coin binding for Python"
+arch=('i686' 'x86_64')
+url="http://pivy.coin3d.org"
+license=('custom')
+depends=('python2' 'soqt')
+makedepends=('swig' 'mercurial')
+source=("pivy::hg+https://bitbucket.org/Coin3D/pivy#tag=pivy-$pkgver")
+md5sums=('SKIP')
+replaces=(pivy)
+provides=(pivy)
+
+package() {
+ cd "$srcdir/pivy"
+
+ python2 setup.py install --root="${pkgdir}"
+
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+