summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76c41ad12255
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+#Automatically generated by pip2arch on 2015-03-02
+pkgname=python2-pprofile
+_name=pprofile
+pkgver=1.7.2
+pkgrel=1
+pkgdesc="Line-granularity, thread-aware deterministic and statistic pure-python profiler"
+url="http://github.com/vpelletier/pprofile"
+depends=('python2')
+makedepends=('python2' 'python2-setuptools')
+license=('GPLv2')
+arch=('any')
+source=("https://pypi.python.org/packages/source/p/${_name}/${_name}-1.7.2.tar.gz")
+md5sums=('54c9cebd083e16849727a0fae7ae5508')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ # Avoid clash with Python 3 version
+ mv "${pkgdir}/usr/bin/pprofile" "${pkgdir}/usr/bin/python2-pprofile"
+}