summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 15 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71f729104e33..b3493db38d38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,23 @@
-# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: jepaan <jepaan at hotmail dot com>
-
-pkgname=python2-pyassimp
-_name=assimp
-pkgver=3.1.1
+_base=assimp
+pkgname=python2-py${_base}
+pkgver=5.2.2
pkgrel=1
-pkgdesc="Portable Open Source library to import various well-known 3D model formats in an uniform manner. Python bindings."
-arch=('i686' 'x86_64')
-license=('BSD')
-depends=('assimp' 'python2')
-url=('http://assimp.sourceforge.net/index.html')
-source=("https://github.com/assimp/assimp/archive/v${pkgver}.tar.gz")
-md5sums=('ab9977edf95e9b2910d7cca286926e85')
+pkgdesc="Python bindings for the Open Asset Import Library (ASSIMP)"
+arch=(any)
+license=('custom')
+depends=(assimp python2)
+makedepends=(python2-setuptools)
+url="https://github.com/${_base}/${_base}"
+source=(${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('7f11f3e53bdcd43a81be49ce2ad90d97769ae1c3c6157f57e8a0b2b41c72f394ad1afcdc5f5fa6fbfa1a44233fed4b9a578d5548ec5b9aae2113ef88c2ec843a')
-build()
-{
- cd ${srcdir}/${_name}-${pkgver}/port/PyAssimp
+build() {
+ cd ${_base}-${pkgver}/port/PyAssimp
python2 setup.py build
}
-package()
-{
- cd ${srcdir}/${_name}-${pkgver}/port/PyAssimp
+package() {
+ cd ${_base}-${pkgver}/port/PyAssimp
python2 setup.py install --root="$pkgdir/" --optimize=1
}