summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28ffa3bda48d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Troy C < rstrox -ta yahoo -tod com >
+
+pkgname=python2-pyrax
+pkgver=1.9.4
+pkgrel=1
+pkgdesc="Python SDK for OpenStack/Rackspace APIs"
+arch=('any')
+url="https://github.com/rackspace/pyrax"
+license=('GPL')
+depends=('python2-rackspace-novaclient>=1.3' 'python2-novaclient>=2.13.0' 'python2-requests' 'python2-keyring' 'python2-mock' 'python2-six')
+makedepends=('python2-setuptools')
+provides=("$pkgname=$pkgver")
+source=("http://pypi.python.org/packages/source/p/pyrax/pyrax-$pkgver.tar.gz")
+md5sums=('aaeafbbd555decf5accea971e91740cf')
+
+build() {
+ cd "$srcdir/pyrax-$pkgver"
+ python2 setup.py build
+}
+package() {
+ cd "$srcdir/pyrax-$pkgver"
+ python2 setup.py install --root=${pkgdir}
+}