summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c48264a7ebb..20cfcacd517a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
-# Maintainer:
-
-pkgname=python2-straight.plugin
-pkgver=1.4.0.p1
-_ver=1.4.0-post-1
+# Contributor: Anatol Pomozov <anatol.pomozov@gmail.com>
+_base=straight.plugin
+pkgname=python2-${_base}
+pkgver=1.5.0
pkgrel=1
pkgdesc='A simple namespaced plugin facility'
arch=(any)
-url='https://github.com/ironfroggy/straight.plugin'
+url="https://github.com/ironfroggy/${_base}"
license=(MIT)
depends=(python2)
-source=(https://pypi.python.org/packages/source/s/straight.plugin/straight.plugin-$_ver.tar.gz)
-md5sums=('e1a22847055f377fa4c9a99d733eb44c')
+makedepends=(python2-setuptools)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('64652f90d6ef02b129b438bfe75781fd259e6ec081b32941c120a64e9591e344c2a0a86ad7b895731af3a95255b230631483eae1bdfe8bc5b21365907758766c')
+
+build() {
+ cd ${_base}-${pkgver}
+ python2 setup.py build
+}
package() {
- cd straight.plugin-$_ver
- python2 setup.py install --root="$pkgdir" --optimize=1
+ cd ${_base}-${pkgver}
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}