summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ece92987e341
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Patrick Guenther <info@paddybu.de>
+
+pkgname=python2-translationstring
+pkgver=20170829
+pkgrel=1
+pkgdesc="A library used for internationalization (i18n) duties related to translation."
+
+url="https://github.com/Pylons/translationstring"
+arch=('any')
+license=('GPL2')
+depends=('python2' 'python2-setuptools')
+makedepends=('git')
+provides=("python2-translationstring")
+#source=('git://gitorious.org/bdflib/mainline.git')
+source=('git://github.com/Pylons/translationstring')
+md5sums=('SKIP')
+
+_gitname="translationstring"
+
+pkgver() {
+ cd $_gitname
+ git show -s --format="%ci" HEAD | sed -e 's/-//g' -e 's/ .*//'
+}
+
+build() {
+ cd $_gitname
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting setup.py..."
+
+ find ./ -type f | xargs -n 1 sed -i 's|/usr/bin/python|/usr/bin/env python2|'
+ python2 setup.py build
+}
+
+package() {
+ cd $_gitname
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}