summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..108e70964bfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Bogdan Szczurek <thebodzio@gmail.com>
+
+pkgname=python2-transmissionrpc
+pkgver=0.11
+pkgrel=1
+pkgdesc="Module to communicate with Transmission BT client via JSON-RPC"
+arch=(any)
+url="https://bitbucket.org/blueluna/transmissionrpc/wiki/Home"
+license=('MIT')
+depends=('python2' 'python2-six')
+makedepends=('python2-setuptools')
+conflicts=('pytransmissionrpc')
+replaces=('pytransmissionrpc')
+source=(https://bitbucket.org/blueluna/${pkgname:8}/get/release-${pkgver}.tar.gz)
+
+package() {
+ cd "$srcdir/blueluna-${pkgname:8}-eb2a32720f8a"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+md5sums=('2ec4dc465435cc970c20f1e10524439b')