summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77df6d4d4a4b..06d61294a6e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,12 @@
# Maintainer: Daniel Bermond < gmail-com: danielbermond >
+# waiting for upstream to finish python3 support
+# https://github.com/Netflix/vmaf/issues/331
+
pkgname=python2-vmaf
_srcname=vmaf
pkgver=1.3.14
-pkgrel=1
+pkgrel=2
pkgdesc='Perceptual video quality assessment algorithm based on multi-method fusion (python2 implementation)'
arch=('any')
url='https://github.com/netflix/vmaf/'
@@ -16,6 +19,7 @@ depends=(
'python2-scikit-image' 'python2-sureal'
)
makedepends=('git' 'python2-setuptools')
+checkdepends=('python2-cloudpickle') #'python2-dask' 'python2-toolz')
source=("${_srcname}-${pkgver}.tar.gz"::"https://github.com/Netflix/${_srcname}/archive/v${pkgver}.tar.gz")
sha256sums=('e405b9716ea194b851b7d341f670e417ec6a319daec74d3e7bf591b71cbbac1c')
@@ -24,18 +28,18 @@ build() {
python2 setup.py build
}
-# waiting for upstream to finish python3 support
-# https://github.com/Netflix/vmaf/issues/128
-# https://github.com/Netflix/vmaf/blob/fcf8c9e695b16f9f3b43af9a4a0c3fb792fc071a/resource/doc/VMAF_Python_library.md
+check() {
+ cd "${_srcname}-${pkgver}/python"
+ python2 setup.py test
+}
package() {
cd "${_srcname}-${pkgver}/python"
- local _script
-
python2 setup.py install --root="$pkgdir" --skip-build --optimize='1'
# vmaf python2 executables
+ local _script
while read -rd '' _script
do
install -D -m755 "$_script" -t "${pkgdir}/usr/bin"