summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2dc1ed42a563..eed3e0771a59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=qmlkonsole-git
-pkgver=r77.0106a20
-pkgrel=2
+pkgver=v21.05.r1.g51d8906
+pkgrel=1
pkgdesc="Terminal app for Plasma Mobile"
-arch=('x86_64')
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://invent.kde.org/plasma-mobile/qmlkonsole"
license=('GPL3')
-depends=('ki18n' 'kconfig' 'kirigami2' 'qmltermwidget' 'qt5-svg')
-makedepends=('git' 'qt5-tools' 'extra-cmake-modules')
+depends=('ki18n' 'kconfig' 'kirigami2' 'qmltermwidget')
+makedepends=('git' 'qt5-tools' 'qt5-svg' 'extra-cmake-modules')
provides=('qmlkonsole')
conflicts=('qmlkonsole')
source=("git+${url}.git")
@@ -23,12 +23,10 @@ pkgver() {
}
build() {
- cd "${pkgname%-git}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -B build
- make -C build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S "${pkgname%-git}"
+ cmake --build build --config RelWithDebInfo
}
package() {
- cd "${pkgname%-git}"
- make -C build DESTDIR="${pkgdir}" PREFIX=/usr install
-}
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
+} \ No newline at end of file