summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 9 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e52ee5b5c48f..becd25e6e16d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,22 @@
# Maintainer: Maarten de Boer <info@maartendeboer.net>
pkgname=('qodana-cli')
-pkgver=2023.2.6
+pkgver=2024.1.6
pkgrel=1
pkgdesc="Simple cross-platform command-line tool to run Qodana linters anywhere with minimum effort required."
arch=('x86_64' 'aarch64')
url="https://github.com/JetBrains/qodana-cli"
-license=('Apache')
-depends=('docker')
-makedepends=('go>=1.19')
+license=('Apache-2.0')
+depends=()
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+source_x86_64=("${pkgname}-${pkgver}.tar.zst::https://github.com/JetBrains/qodana-cli/releases/download/v${pkgver}/qodana_${pkgver}_linux_amd64.pkg.tar.zst")
+source_aarch64=("${pkgname}-${pkgver}.tar.zst::https://github.com/JetBrains/qodana-cli/releases/download/v${pkgver}/qodana_${pkgver}_linux_arm64.pkg.tar.zst")
-sha256sums=('88a21a6d292c4723a68c9b5e1b5f180ce9e07e116dff8f4e7599eff01ffc7f7f')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- # See: https://wiki.archlinux.org/index.php/Go_package_guidelines
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOPATH="${srcdir}/go"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
-
- go mod tidy
- go build
-}
+sha256sums_x86_64=('98c01f8a1839c015e5d45f26abd1c5b6ff1db3ef1726512980a29dc683a4b45f')
+sha256sums_aarch64=('98c01f8a1839c015e5d45f26abd1c5b6ff1db3ef1726512980a29dc683a4b45f')
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- install -Dm0755 qodana-cli "${pkgdir}/usr/bin/qodana"
+ cd "${srcdir}"
- install -Dm0644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm0644 THIRDPARTY.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm0755 usr/bin/qodana -t "${pkgdir}/usr/bin"
}