summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD45
1 files changed, 25 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ef04db497ac2..e407d67c7b2d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Alexander Bantyev <balsoft@yandex.ru>
pkgname=qomp-git
-pkgver=1.4.r7.gcb19e84
-pkgrel=2
+pkgver=1.5.r16.g5e58fcb
+pkgrel=1
pkgdesc="Quick(Qt) Online Music Player"
arch=(i686 x86_64)
url="https://github.com/qomp/qomp"
@@ -16,41 +16,46 @@ optdepends=('gst-libav: additional codecs'
'gst-plugins-bad: additional codecs'
'gst-plugins-ugly: additional codecs')
makedepends=(git cmake qt5-tools)
-source=("${pkgname}::git+https://github.com/qomp/qomp"
- "git+https://github.com/qomp/translations"
- "git+https://github.com/qomp/themes"
+source=("git+https://github.com/qomp/qomp.git"
+ "qomp-translations::git+https://github.com/qomp/translations.git"
+ "qomp-themes::git+https://github.com/qomp/themes.git"
+ "git+https://github.com/wadealer/qt-google-analytics.git"
"git+https://github.com/wadealer/SingleApplication")
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/qomp"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/qomp"
git submodule init
- git config 'submodule.translations.url' "${srcdir}/translations"
- git config 'submodule.themes.url' "${srcdir}/themes"
- git config 'submodule.src/singleapplication.url' "${srcdir}/SingleApplication"
- git submodule update
+ git config submodule.translations.url "${srcdir}/qomp-translations"
+ git config submodule.themes.url "${srcdir}/qomp-themes"
+ git config submodule.ga.url "${srcdir}/qt-google-analytics"
+ git config submodule.src/singleapplication.url "${srcdir}/SingleApplication"
+ git config submodule.android_openssl.update none
+ git -c protocol.file.allow=always submodule update
+
+ [[ -d build ]] || mkdir build
}
build() {
- cd "${srcdir}/${pkgname}"
-
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr/ \
+ cd "${srcdir}/qomp/build"
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release
-make
+ make
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/qomp/build"
make DESTDIR="$pkgdir/" install
}