summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a19d0a14a7b..10822987b8d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,15 @@
pkgname=qpdfview
pkgver=0.4.16
-pkgrel=2
+pkgrel=3
pkgdesc='A tabbed PDF viewer using the poppler library.'
arch=('i686' 'x86_64' 'armv7h')
url='https://launchpad.net/qpdfview'
license=('GPL2')
depends=('libcups' 'poppler-qt5' 'qt5-svg' 'desktop-file-utils' 'hicolor-icon-theme')
-optdepends=('libspectre: for PostScript support (required at build time)' 'djvulibre: for DjVu support (required at build time)')
+optdepends=('texlive-bin: for shared SyncTeX parser library (required at build time)'
+ 'libspectre: for PostScript support (required at build time)'
+ 'djvulibre: for DjVu support (required at build time)')
makedepends=('qt5-tools')
install='qpdfview.install'
source=("https://launchpad.net/$pkgname/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz")
@@ -34,5 +36,9 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
make "INSTALL_ROOT=$pkgdir" install
+
+ if pkg-config --exists synctex; then
+ depends=("${depends[@]}" 'texlive-bin')
+ fi
}