summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afb71835f9e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: VirtualTam
+# Maintainer: MCMic <come.bernigaud@laposte.net>
+
+pkgname=qphotobooth-git
+pkgver=929f8d6
+pkgrel=1
+pkgdesc="Photo booth implementation for parties."
+arch=('i686' 'x86_64')
+url="http://projects.haxx.es/p/qphotobooth/"
+license=('BSD')
+depends=('opencv' 'qt5-base' 'qt5-sensors' 'qt5-webkit' 'qt5-multimedia')
+makedepends=('git' 'cmake')
+conflicts=()
+provides=('qphotobooth')
+replaces=('qphotobooth')
+_gitname="qphotobooth"
+source=(git://haxx.es/qphotobooth.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ${_gitname}
+ git describe --always | sed 's|-|.|g'
+}
+
+build(){
+ cd ${_gitname}
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd ${_gitname}/
+ make install DESTDIR=$pkgdir
+}