aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a2946bc7e14..c452b446ed1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -208,7 +208,7 @@ if ${_use_mesa}; then
_profiled_gpu_fn=qpi-mesa.sh
_additional_configure_flags="$_additional_configure_flags -gbm -kms"
else
- if [[ -f ${__eglpkgconfigpath} ]] || [[ -f ${__glespkgconfigpath} ]] ; then
+ if $_building && ([[ -f ${__eglpkgconfigpath} ]] || [[ -f ${__glespkgconfigpath} ]]); then
echo "Mesa is about to eat our communal poodle; delete egl.pc and glesv2.pc in your sysroot"
exit 1
fi