summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46895c1e2490..63f1daef8ed9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=ASpli
-_pkgver=2.12.0
+_pkgver=2.14.0
pkgname=r-${_pkgname,,}
-pkgver=2.12.0
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='Analysis of Alternative Splicing Using RNA-Seq'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('GPL')
+pkgdesc="Analysis of Alternative Splicing Using RNA-Seq"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('GPL-2.0-or-later')
depends=(
- r
r-annotationdbi
r-biocgenerics
r-biocstyle
@@ -29,17 +28,19 @@ depends=(
r-rsamtools
r-s4vectors
r-tidyr
+ r-txdbmaker
r-upsetr
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('5e9ec698127d453cde27310b815b047da4114e0c89a00032104c38b7f7004166')
+md5sums=('0c318ecaa7d695b92852277fb46a2c05')
+b2sums=('fba656c6321a757e9575e53aa57b499f0b40e60ade6e9014b27cd12bb02e9b9260eff3f74395a0b1d56babf37d3a98277f5b2ca0cafc468fa394fefd222cbb50')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: