summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86050e1d677e..a1ff825ca127 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,39 @@
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=densityClust
-_pkgver=0.3.2
+_pkgver=0.3.3
pkgname=r-${_pkgname,,}
-pkgver=0.3.2
-pkgrel=6
-pkgdesc='Clustering by Fast Search and Find of Density Peaks'
-arch=('x86_64')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Clustering by Fast Search and Find of Density Peaks"
+arch=(x86_64)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-or-later')
depends=(
- r
r-fnn
r-ggplot2
r-ggrepel
r-gridextra
r-rcolorbrewer
- r-rcpp
r-rtsne
)
+makedepends=(
+ r-cpp11
+)
optdepends=(
r-covr
r-testthat
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('1a47b1384aeaf4734b5766567b1ce0fed221094813b91aad7879daf64374a217')
+md5sums=('c0ac3de082d380e4c7f2a04a6a573c0a')
+b2sums=('a0692a519402cb0932fd08b9fc489a604d39ea74496ef47db4fa0efec1830447b2152c353d8130de913cd5290bb38bcdbc995171e6b52db1a4b9eccabbda2633')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: