summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62d87cc33e85..4492701a93f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=EpiTxDb
-_pkgver=1.14.1
+_pkgver=1.16.0
pkgname=r-${_pkgname,,}
-pkgver=1.14.1
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='Storing and accessing epitranscriptomic information using the AnnotationDbi interface'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('Artistic2.0')
+pkgdesc="Storing and accessing epitranscriptomic information using the AnnotationDbi interface"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('Artistic-2.0')
depends=(
- r
r-annotationdbi
r-biocfilecache
r-biocgenerics
@@ -23,9 +22,11 @@ depends=(
r-httr
r-iranges
r-modstrings
+ r-rex
r-rsqlite
r-s4vectors
r-trnadbimport
+ r-txdbmaker
r-xml2
)
optdepends=(
@@ -43,14 +44,15 @@ optdepends=(
r-txdb.hsapiens.ucsc.hg38.knowngene
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('ad425f358f3cd7b31efb8c29069b204bd9b83d90cf13638dd92f704826c78762')
+md5sums=('20e35a30fee32809fda75ba666f36a8c')
+b2sums=('ba8bf305321b12954444d77c2f46b35b1bccfb6e5f7da515192c9dde0fcecee8b2f8055f6dc4b9dcec8ee29f4a9a4472b4a9d82867135c600832ca7e7fc66b5d')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: