summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c85fbd59d53a..6d05f4a1ca45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,26 @@
_pkgname=evmix
_pkgver=2.12
pkgname=r-${_pkgname,,}
-pkgver=2.12
-pkgrel=3
-pkgdesc='Extreme Value Mixture Modelling, Threshold Estimation and Boundary Corrected Kernel Density Estimation'
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=6
+pkgdesc="Extreme Value Mixture Modelling, Threshold Estimation and Boundary Corrected Kernel Density Estimation"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-3.0-only')
depends=(
- r
r-gsl
r-sparsem
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('6e47d53463b68ac2782201bcc6240fbc5263b2db1ac0d383062032ab135b2a0b')
+md5sums=('20660d1aedd961d7c1224679ab25328c')
+b2sums=('dd63aa8b37f2a4be16c760fccb52dc704059304f01ddf5df5e150eed44df6407b60efd9faf3c54bd8013feff9144e558f85d3c63b23ea221734ee0a8fc17f983')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: