summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6891ced428b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=HiveR
+_pkgver=0.3.63
+pkgname=r-${_pkgname,,}
+pkgver=0.3.63
+pkgrel=3
+pkgdesc='2D and 3D Hive Plots for R'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-jpeg
+ r-plyr
+ r-png
+ r-rcolorbrewer
+ r-rgl
+ tk
+)
+optdepends=(
+ r-bipartite
+ r-funcmap
+ r-knitr
+ r-rmarkdown
+ r-sna
+ r-tint
+ r-xtable
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('83c16ab55324f51ac3f5d0377244fddcb7a009ae30cee4dd67270035c42422ee')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: