summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e3ec447ce4e..dc1c0237652b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,25 @@
_pkgname=intervals
_pkgver=0.15.4
pkgname=r-${_pkgname,,}
-pkgver=0.15.4
-pkgrel=1
-pkgdesc='Tools for Working with Points and Intervals'
-arch=('x86_64')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('Artistic2.0')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Tools for Working with Points and Intervals"
+arch=(x86_64)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('Artistic-2.0')
depends=(
r
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('50c0e1e3aab3e7b72cc1f0a6559d96caa3a360e969c38538479907e6cbe39f8f')
+md5sums=('3ae67facc1528d3626057793aa553924')
+b2sums=('e77edfab823a5c06345f631832ac2b7174ce7eb7153d3eaccd40414034c853959b1c2d5bd54bb39177a68b6f51e1fc423f55e12560a131bbd4f43b357498c110')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: