summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fec070b14e64..a7ef38179156 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,25 @@
_pkgname=NCmisc
_pkgver=1.2.0
pkgname=r-${_pkgname,,}
-pkgver=1.2.0
-pkgrel=3
-pkgdesc='Miscellaneous Functions for Creating Adaptive Functions and Scripts'
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=5
+pkgdesc="Miscellaneous Functions for Creating Adaptive Functions and Scripts"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-2.0-or-later')
depends=(
r
)
-optdepends=(
- r-kernsmooth
- r-matrix
-)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('26fcfbc79810f23a28389a5ce5519e6ddc2470c5e924ba8cf4dd19a1b0fd9f83')
+md5sums=('d3e09dcb38e0f2042a683d2c50b5da21')
+b2sums=('bfbd15279bdc5f254522d4eb1d548c4329b520c986208e8b670428c4f4a28cb016fd8e53f925e93974117bcf1c62565ba79f42f0968b8a170fc00044821de09d')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: