summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 24 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 96ae2fa14182..49e21c766a75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgdesc="Encapsulated Classes with Reference Semantics"
url="https://cran.r-project.org/package=${_cranname}"
license=("MIT")
pkgver=${_cranver//[:-]/.}
-pkgrel=3
+pkgrel=4
arch=("any")
depends=(
@@ -18,10 +18,25 @@ depends=(
optdepends=(
"r-pryr"
)
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat"
-)
+
+# The unittests for `r-r6` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-r6`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
b2sums=("0045d7c37dfb7a773cd24e85e695575eaf6aa5c9392fb6888c10aa9fb3e35b13a230ed0aabcf84d52e656ef506ab58371044c4179b3380f5324b217fae6daeb4")
@@ -31,15 +46,14 @@ build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- cd "${srcdir}/${_cranname}/tests"
- R_LIBS="${srcdir}/build/" Rscript --vanilla testthat.R
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi